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Home > Success Center > Firewall Security Manager (FSM) > Evaluate Checks Report has encountered a problem

Evaluate Checks Report has encountered a problem

Updated March 10, 2017

Overview

When running the Evaluate Checks Report for any firewall in the inventory, you get an error referring to the applicationContext.xml file that it cannot be opened because it does not exist.

Environment

FSM 6.6.5 and 6.6.8

Cause 

There was an issue during the upgrade process.

Resolution

  1. Create a backup of the FSM installation folder. Copy C:\Program Files\SolarWinds\SolarWinds FSMServer.
  2. Uninstall FSM from Programs and Features.
  3. Select Uninstall firebird and Delete data. 
  4. Run the FSM 6.6.8 installer and go through installation process. On the last page, deselect the Launch SolarWinds FSM now? checkbox.
  5. Stop Windows service FirebirdServerDefaultInstance. 
  6. Replace file C:\Program Files\SolarWinds\SolarWinds FSMServer\data\fsm_server.fdb with the file \data\fsm_server.fdb from step 1. 
  7. Start the Firebird service. 
  8. Run FSM and check if the report is generating successfully.

 

Last modified
22:31, 9 Mar 2017

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