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Home > Success Center > Enterprise Operations Console (EOC) > Unable to add group account in EOC

Unable to add group account in EOC

Created by Robert Stidman, last modified by MindTouch on Jun 23, 2016

Views: 3 Votes: 0 Revisions: 4

Overview

This article describes the issue when adding a group account in EOC as admin, the following prompt appears:

Members of the following group (group name) is already assigned to another role

Environment

EOC version a1.X

Cause 

This issue occurs because the AZMAN file does not match the accounts table in EOC DB similar to the SID. 

Resolution

  1. Find the SID of the group account. A utility like WMIC could be used for this and it can be found on Google with instructions for its command line use.
  2. Take a backup of the AZMAN file at C:\Program Files (x86)\SolarWinds\EOC\Website\App_Data on EOC server.
  3. Locate the <Member>[SID OF GROUP ACCOUNT]</Member> between <AzRole ...> and </AzRole> tags in AZMAN file. !!!!! Replace [SID OF GROUP ACCOUNT] with actual SID.
  4. Remove the <Member>[SID OF GROUP ACCOUNT]</Member> under <AzRole ...> tag.
  5. Save the AZMAN file.
  6. Add the group again.

 

Last modified
19:26, 22 Jun 2016

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