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Home > Success Center > Enterprise Operations Console (EOC) > Unable to access credentials or other data after moving Orion EOC to a new server

Unable to access credentials or other data after moving Orion EOC to a new server

Created by Elvin Perez, last modified by MindTouch on Jun 23, 2016

Views: 588 Votes: 1 Revisions: 8

Overview

This article describes the issue when accessing credentials or other data after moving Orion EOC to a new server.

Environment

All versions of EOC 

Cause

Orion EOC encrypts sensitive data with a security certificate stored on the original Orion EOC server. Hence, moving to new server this certificate will change and causing the issue accessing encrypted data.

Resolution

  1. Export the certificate from the original server:
    1. On the Start Menu, click Run, type MMC, and then click OK.
    2. On the File menu, click Add/Remove Snapin, and then click Add.
    3. Select Certificates, and then click Add.
    4. Select Computer account, and then click Next.
    5. Select Local computer, and then click Finish.
    6. Click Close.
    7. Click OK.
    8. Expand the Certificates (Local Computer) group.
    9. Expand the Personal group.
    10. Expand the Certificates group.
    11. Right-click SolarWinds EOC, point to All Tasks on the shortcut menu, and then click Export.
    12. Click Next in the Certificate Export Wizard.
    13. Select Yes, export the private key, click Next, and then click Next again.
    14. Type and confirm a password for this private key, and then click Next.
    15. Specify the file name to which you want to save the certificate, click Next, and then click Finish—the certificate is saved with a .pfx file name extension.
  2. Import the certificate to the new computer:
    1. Copy the .pfx certificate file to the new computer.
    2. On the Start Menu, click Run, type MMC, and then click OK.
    3. On the File menu, click Add/Remove Snapin, and then click Add.
    4. Select Certificates, and then click Add.
    5. Select Computer account, and then click Next.
    6. Select Local computer, and then click Finish.
    7. Click Close.
    8. Click OK.
    9. Expand the Certificates (Local Computer) group.
    10. Expand the Personal group.
    11. Expand the Certificates group.
    12. If there is a SolarWinds EOC item in the list, right-click SolarWinds EOC, and then click Delete on the shortcut menu.
    13. Right-click the Certificates—Personal—Certificates node, point to All Tasks in the shortcut menu, and then click Import.
    14. Click Next in the Certificate Import Wizard.
    15. Specify the .pfx certificate file you copied to the server, and then click Next.
    16. Enter the password for the private key, check Mark this key as exportable, and then click Next.
    17. Select Place all certificates in the following store, and then select Personal as the Certificate Store.
    18. Click Next, and then click Finish.
  3. Copy the Authorization Manager file to the new computer:
    1. Locate the Az_databaseInfo.xml file in the Website\App_Data folder of the original Orion EOC server. Typically, it is located in C:\Program Files\SolarWinds\EOC\Website\App_Data.
    2. Copy the .xml file to the Website/App_data folder of the new Orion EOC server. Typically, this is C:\Program Files\SolarWinds\EOC\Website\App_Data.
  4. Re-run the EOC Configuration Wizard to reconfigure the database on the new computer:
    1. Start Orion EOC Configuration Wizard in the SolarWinds Orion Enterprise Operations Console program group.
    2. Check Database, and then click Next.
    3. Click Next on the wizard dialog boxes until the Orion EOC Configuration Wizard has repaired the database.
    4. Click Finish.

 

Last modified
19:26, 22 Jun 2016

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