Submit a ticketCall us

Training ClassSign up for Network Performance Monitor (NPM) and Scalability instructor-led classes

Attend our instructor-led classes, provided by SolarWinds® Academy, to discuss the more advanced monitoring mechanisms available in NPM as well as how to tune your equipment to optimize its polling capabilities. NPM classes offered:
NPM Custom Monitoring and Polling
Orion Platform Scalability

Reserve your seat.

Home > Success Center > Enterprise Operations Console (EOC) > EOC - Knowledgebase Articles > There is a problem storing NCM module results

There is a problem storing NCM module results

Updated May 4, 2017

Overview

The following error message is displayed when polling or storing NCM module results from the SolarWinds server in EOC:

There is a problem storing NCM module results.

 

EOC: There is a problem storing NCM module results

 

The following error is also seen in the EOC.PollingService.log file:

2017-04-27 03:50:08,268 [10] 2 Orion.Module.NCM ERROR SolarWinds.EOC.PollingService.JobHandlers.OrionPollJobResultHandler - Error committing data for table 'EOC_NCM_GlobalSettings'
System.Data.SqlClient.SqlException (0x80131904): Received an invalid column length from the bcp client for colid 3.
[..]
Error Number:4815,State:1,Class:17

Environment

EOC 1.6.3 and earlier

Cause 

The Error Number:4815,State:1,Class:17 message in the EOC.PollingService.log file suggests a data compatibility issue, mostly the data length on a bulk copy (bcp). The error message also shows which table (EOC_NCM_GlobalSettings) and column (colid 3) it relates to. In this case, the SettingValue column is affected.

Resolution

As a workaround, either make the EOC table's column of the same data length or apply maximum size to the column using the following example query:

DELETE FROM [dbo].[EOC_NCM_GlobalSettings] 

ALTER TABLE [dbo].[EOC_NCM_GlobalSettings]
ALTER COLUMN [SettingValue] [varchar](max) NOT NULL;

 

Last modified

Tags

Classifications

Public