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Home > Success Center > Enterprise Operations Console (EOC) > EOC - Knowledgebase Articles > NCM Configs page times out in EOC

NCM Configs page times out in EOC

 

Overview

This article details an issue in which the NCM tab in EOC times out and EOC_ConfigArchive generates thousands of rows.

 

The EOC.InformationService.log displays the following error prompt:

017-02-17 08:10:34,961 [27] ERROR SolarWinds.InformationService.Core.InformationService - Exception caught in method RunQuery
System.Data.SqlClient.SqlException: A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.)

Environment

  • All supported versions of EOC

Cause 

There are too many configurations to display, resulting in a time out.

Resolution

Modify C:\Program Files (x86)\SolarWinds\EOC\Bin\Queries\NCM.xml. The Depth value will control how many hours of configs to download (default 1 year).

 

There is an issue with Time Zone conversion between EOC and Orion and you have to add 24 hours to the desired depth value. For example: 48 (2 days of configs) + 24 = 72 for the Depth value.

  <HistoryLimit>
                <Column>ModifiedTime</Column>
                <Depth>8760</Depth> <!-- 1 year in hours -->
                <Enabled>true</Enabled> <!-- If you want to poll all Config Archives, change the true to false -->
            </HistoryLimit>

 

 

 

 

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