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Home > Success Center > Enterprise Operations Console (EOC) > EOC fails to poll when Job DLL is not unblocked

EOC fails to poll when Job DLL is not unblocked

Created by Robert Stidman, last modified by MindTouch on Jun 23, 2016

Views: 7 Votes: 0 Revisions: 3

Overview

This article describes the issue when EOC fails to poll because Job DLL does not unblock. 

Some EOC hotfixes require solarwinds.eoc.jobs.dll to be replaced, and that may cause the file to block. Normally, right-clicking the file and going to properties, then clicking unblock fixes the issue. There are cases where it does not unblock leaving the polling to fail. 

Environment

Alll versions of EOC

Cause 

This issue occurs due to Windows file security.

 

Resolution

  1. Find the solarwinds.eoc.jobs.dll file in c:\program files (x86)\eoc\bin.
  2. Move the file to a temp folder.
  3. Unblock it in the temp folder
  4. Rename the old file in the original folder and replace it with the file from the temp folder
  5. Check properties to make sure that it is still unblocked. 
  6. Restart all Solar\Winds services in the Windows services.msc snap-in.

 

Last modified
19:24, 22 Jun 2016

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