Submit a ticketCall us

whitepaperYour VM Perplexities Called, and They Need You to Read This.

Virtualization can give you enormous flexibility with future workloads and can be a key enabler for other areas, like cloud computing and disaster recovery. So, how can you get a handle on the performance challenges in your virtual environment and manage deployments without erasing the potential upside? Learn the four key areas you need to be focusing on to help deliver a healthy and well-performing data center.

Get your free white paper.

Home > Success Center > Engineers ToolSet (ETS) > ETS - Knowledgebase Articles > Error when installing Engineer's Toolset: Microsoft .Net Framework 4.0 is required by SolarWinds Toolset v11. Install .Net Framework 4.0 and rerun the installer

Error when installing Engineer's Toolset: Microsoft .Net Framework 4.0 is required by SolarWinds Toolset v11. Install .Net Framework 4.0 and rerun the installer

Updated November 23, 2018

Overview

The following error occurs when installing ETS on Windows: 
.net 4 services not available please install

 

or

 

Microsoft .Net Framework 4.0 is required by SolarWinds Toolset v11. Install .Net Framework 4.0 and rerun the installer:

 

net-framework-4-0-required.PNG

Environment

  • ETS version 10.0 to 11.0.6
  • Windows 10

Cause 

This error occurs when legacy .Net software packages are not enabled. 

Resolution

  1. Add the .Net Framework 3.5 features.

    The same message, stating that 4.0 is required, is in situations where 4.0 is installed but .Net Framework 3.5 is not installed. To fix the error in this case, install .Net Framework 3.5 and other legacy .Net software packages.

  2. Under programs and features, include .Net 2.0 and 3.0.
  3. You may also disable this from your domain's GPO.  

 

Last modified

Tags

Classifications

Public