Submit a ticketCall us
Home > Success Center > Engineers ToolSet (ETS) > Error when installing Engineer's Toolset: Microsoft .Net Framework 4.0 is required by SolarWinds Toolset v11. Install .Net Framework 4.0 and rerun the installer

Error when installing Engineer's Toolset: Microsoft .Net Framework 4.0 is required by SolarWinds Toolset v11. Install .Net Framework 4.0 and rerun the installer

Updated September 14th, 2017

Overview

The following error occurs when installing ETS on Windows: 
.net 4 services not available please install

 

or

 

Microsoft .Net Framework 4.0 is required by SolarWinds Toolset v11. Install .Net Framework 4.0 and rerun the installer:

 

net-framework-4-0-required.PNG

Environment

  • ETS version 10.0 to 11.0.6
  • Windows 10

Cause 

This error occurs when Legacy .Net software packages are not enabled. 

Resolution

  1. Add the .Net Framework 3.5 features. Note: While the error specifies .Net Framework 4.0, the same message will appear when .Net Framework 3.5 is not installed.
  2. Under programs and features, include .Net 2.0 and 3.0.
  3. You may also disable this from your domain's GPO.  

 

Last modified

Tags

Classifications

Public