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Home > Success Center > Engineer's ToolSet (ETS) > Toolset tab in Orion Web interface not providing tools after implementing Hotfix 1 for Toolset on the Web 11.0.1

Toolset tab in Orion Web interface not providing tools after implementing Hotfix 1 for Toolset on the Web 11.0.1

Created by Chris Foley, last modified by MindTouch on Jun 23, 2016

Views: 31 Votes: 0 Revisions: 5

Overview

After implementing HotFix 1 for Toolset on the Web 11.0.1, the Toolset tab within the Orion Web interface is no longer providing tools. The error returned within the Web Resources is There was an error rendering.  If you then click "View Details", you get "There was no response from the Toolset Service Engine located at "[Orion Address]:17777.

Environment

  • Toolset v11 and later
  • All versions of Windows

Cause 

This normally occurs if the new DLL file contained in the HotFix zip file is not unblocked before being implemented.

Resolution

  1. Extract the HotFix zip file to your desktop.
  2. Right-click the extracted SolarWinds.Toolset.BusinessLayer.dll file and click "Properties".
  3. Click the "unblock" button.

 

Once this has been completed, reimplement the HotFix using the following steps:

  1. Stop all Orion services using the Orion Service Manager.
  2. Copy the SolarWinds.Toolset.BusinessLayer.dll to the Toolset installation location (\Program Files (x86)\SolarWinds\Orion\Toolset), replacing the current file.
  3. Start all Orion services using the Orion Service Manager.
Last modified
19:23, 22 Jun 2016

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