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Home > Success Center > DameWare Remote Support & Mini Remote Control > DameWare - Knowledgebase Articles > Error on accounts synchronization with Active Directory

Error on accounts synchronization with Active Directory

Created by Marlo Bidayan, last modified by MindTouch on Jun 23, 2016

Views: 908 Votes: 0 Revisions: 4

Overview

There is an error 99 on the XML importation logs.

Environment

DameWare Central Server 

Cause

This is caused by a foreign key error in the database.

Resolution

  1. Download an SQL compact editor.
  2. Create a backup of the database.
  3. Open the database with the editor.
  4. Locate the Foreign key based on the XML logs from the Central Server.
  5. Run the following SQL query.
    DELETE FROM CentralServer_HostLists WHERE Owner = '6be46a66-21ea-46c6-8056-f2d4e48c11f3'
    DELETE FROM CentralServer_LicensedUsers WHERE ID = '6be46a66-21ea-46c6-8056-f2d4e48c11f3'

    Note: The first query deletes a related row in HostList and second query deletes user with specific ID.
  6. Stop the DameWare Central Server service and copy the edited database.
  7. Start the service.
  8. Run the synchronization process again for the accounts.

 

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