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Home > Success Center > Access Rights Manager (ARM) formerly 8MAN > ARM - Knowledgebase Articles > Base container missing in Data Owner Configuration

Base container missing in Data Owner Configuration

Updated November 20, 2018

Overview

This article details an issue in which the base container has been deleted from the ARM Data Owner Configuration. If the configuration does not have a base container, it is not possible to create a new container.

 

Environment

  • Access Rights Manager

Cause

The cause of this issue is unknown.

Resolution

 

  • An update or a new installation will not resolve this issue. 
  • You can create a new base container using the import function.

 

  1. Create a JSON file with the following content:
    {
      "$type": "pn.server.dataOwner.PersistedDataOwnerOrganizationTree, libCommon",
      "OrganizationId": "140bc8e7-9e6d-49ac-80b5-c0b286aa8629",
      "Name": "Die Firma",
      "Description": null,
      "Children": [],
      "Properties": {
        "DataOwners": [],
        "Resources": [],
        "Requesters": [],
        "Workflow": null,
        "GroupWizardConfiguration": null,
        "Id": "e3df4766-2a52-4b4b-8159-27d069f5a418",
        "IsPersistable": true
      },
      "Id": "f46deac3-03a1-432a-ba3b-00f91fac394f",
      "IsPersistable": true
    }
    
  2. In Data Owner configuration click Import.
  3. Browse to and load the file into the Data Owner Configuration.
  4. If you have already configured Data Owners, deactivate the option "Do not remove all ...". 
  5. This will keep the already configured Data Owners.
  6. You now have a base container again and can add resources or create sub containers.

 

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